Mein Variomedia

Hier können Sie sich im Kundenmenü einloggen.




Passwort vergessen?

Weitere Logins

Sie befinden sich hier: variomedia.de > Support > Häufige Fragen (FAQ) > Webanwendungen und Datenbanken > PHP

Fragen und Antworten

Wie installiere ich den Composer für PHP?

Der Composer ist auf allen Webservern vorinstalliert, er ist sowohl in Version 1 als auch in der aktuellen Version 2 verfügbar.

Composer aufrufen

Sie können Composer per SSH mit dem Befehl composer (Version 2.x) bzw. composer1 (Version 1.x) aufrufen.

PHP Version für Composer ändern

Der vorinstallierte Composer nutzt die Standard-PHP-Version des Webservers. Sie können Composer auch mit einer abweichenden PHP-Version nutzen. Sie können dazu Composer mit der gewünschten PHP-Version aufrufen (z.B. php74 /usr/bin/composer für PHP 7.4), oder sie setzen die gewünschte PHP-Version als Standard in der Shell (beachten Sie dazu den untern verlinkten FAQ Artikel).

Links


Composer
PHP